Results 1 to 11 of 11

Thread: ePSXE games running too fast

  1. #1
    Join Date
    Sep 2018
    Posts
    5
    Thanks
    1
    Thanked 1 Time in 1 Post
    EP Points
    5

    Default ePSXE games running too fast

    Hello my computer specs are:
    RAM - 16GB
    Graphics - Nvidia Geforce GTX 960m
    Processor - Intel Core i7-6700HQ CPU @ 2.60GHz

    My ePSXe settings are:
    ePSXE 2.0.5
    BIOS - scph1001 - US
    Video - Pete's OpenGL2 Driver 2.9
    Sound - ePSXE SPU core 2.0.0
    Cdrom - ePSXe CDR WNT/W2K core 2.0.0

    When I run games, everything goes way too fast. This has been tested on Suikoden 1. At the start menu, the "Press Start" display spins too fast. Then you go into 'New Game' and the character spins too fast and when you move the cursor to select name, that is also moving too fast. Upon starting the game, even the character is moving too fast.

    What can I do to slow down everything and get it to correct settings? I've tried setting a FPS limit to 60, but even with Auto-detect on it is still running at 60FPS. I've tried 20-30FPS because I heard PS1 games run at that level but it gets really choppy. I even tried Frame skipping but the frames are still running at fast speeds, just skipping a couple frames.

    I first tried 'Nice' settings and had this issue before I began looking online on how to fix it. I set everything to the max and it still doesn't work.

    Please recommend a solution. I've attached an image of my current video settings. Thanks!
    Attached Images Attached Images  

  2. #2
    Join Date
    May 2018
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    200fps???? 30...

  3. #3
    Join Date
    Sep 2018
    Posts
    5
    Thanks
    1
    Thanked 1 Time in 1 Post
    EP Points
    5

    Default

    Quote Originally Posted by Rodrigao View Post
    200fps???? 30...
    What a insightful and detailed answer. As you can see from the pic, it's checked on auto-detect. Changing the numbers doesn't change anything (I've just tried it). Even setting the limiter to 60 makes the game still run fast. For some reason, when I set it to 30, the game is still running at 60 FPS. I have FPS display turned on just so I can check it. Even messed with Frame Skipping a little and that definitely doesn't do the trick. Could this be because my computer is too overpowered for ePSXe? I've tried multiple fixes (they are all saying use FPS limit and input FPS limit to 60) and none of them has worked for me.
    Literally the only different fix I saw was to use a different emulator, but I recall using ePSXe in the past on an older computer and it was running fine. It was perfect.

  4. #4
    Join Date
    May 2002
    Location
    V.C. B.C. Canada
    Posts
    11,993
    Thanks
    104
    Thanked 608 Times in 263 Posts
    EP Points
    445

    Default

    judging by the picture you have to also click the little circle for fps limit (10-200) which will uncheck the autodetect circle and set it to 63 fps and keep the fps limit box checked (just having this box checked does nothing if you don't click the little circle where you can enter a value) hope that makes sense.


  5. #5
    Join Date
    Sep 2018
    Posts
    5
    Thanks
    1
    Thanked 1 Time in 1 Post
    EP Points
    5

    Default

    Quote Originally Posted by Zaladane View Post
    judging by the picture you have to also click the little circle for fps limit (10-200) which will uncheck the autodetect circle and set it to 63 fps and keep the fps limit box checked (just having this box checked does nothing if you don't click the little circle where you can enter a value) hope that makes sense.
    Hi I've tried ticking the check box before. Even with setting the FPS limit to 30FPS with the box ticked, it for some reason still runs at 60FPS. But this is with me using a different ePSXe download. The original one that I tried it on did work, but the frames were still too choppy

  6. #6
    Join Date
    Sep 2018
    Posts
    5
    Thanks
    1
    Thanked 1 Time in 1 Post
    EP Points
    5

    Default

    Okay so here was my "fix" that I found worked. Instead of using ePSXe v2.0.5, I instead used the prior version of ePSXe v2.0.2-1 Windows. Emuparadise only provides the latest version so I got my copy from ePSXe's website.
    http://www.epsxe.com/download.php
    I use the same files that I used for ePSXe v2.0.5, which are the same files you see at the very top. I hope this helps anyone.

  7. #7
    Join Date
    Dec 2013
    Posts
    3
    Thanks
    2
    Thanked 2 Times in 1 Post
    EP Points
    10

    Default

    When opening ePSXe, go to options and make sure CPU overclocking is set to x1. This will fix all frame rate issues.By default no option is selected in CPU overclocking, which makes ePSXe run at full throttle or whatever you CPU/GPU fps can achieve.Click image for larger version. 

Name:	psx.jpg 
Views:	84 
Size:	94.1 KB 
ID:	56930

  8. The Following 2 Users Say Thank You to xXAdolXx For This Useful Post:


  9. #8
    Join Date
    Sep 2018
    Posts
    5
    Thanks
    1
    Thanked 1 Time in 1 Post
    EP Points
    5

    Default

    Quote Originally Posted by xXAdolXx View Post
    When opening ePSXe, go to options and make sure CPU overclocking is set to x1. This will fix all frame rate issues.By default no option is selected in CPU overclocking, which makes ePSXe run at full throttle or whatever you CPU/GPU fps can achieve.Click image for larger version. 

Name:	psx.jpg 
Views:	84 
Size:	94.1 KB 
ID:	56930
    Holy cow that actually fixed it. Upon first installation,CPU overclocking was already ticked at x1 so I thought it was already done. I decided to just humor you and do it and it actually worked. Thanks! If there was an upvote button, I'd be hitting it right about now

  10. The Following User Says Thank You to LaughingHand For This Useful Post:


  11. #9
    Join Date
    Jun 2009
    Posts
    18,325
    Thanks
    628
    Thanked 1,251 Times in 773 Posts
    EP Points
    8240

    Default

    Quote Originally Posted by LaughingHand View Post
    Holy cow that actually fixed it. Upon first installation,CPU overclocking was already ticked at x1 so I thought it was already done. I decided to just humor you and do it and it actually worked. Thanks! If there was an upvote button, I'd be hitting it right about now
    You've already used the thanks button which gives rep, there's also a rep+ option (the star). But if you have 0 rep power neither boosts the receiver's rep level.

    Spoiler warning:

  12. #10
    Join Date
    Dec 2013
    Posts
    3
    Thanks
    2
    Thanked 2 Times in 1 Post
    EP Points
    10

    Default

    You are welcome man! I ran into this problem when ePSXe 2.0.5 first came out and even tho it said the CPU overclocking was set, it wasn't and had to be set so it could be saved to the config file.

  13. #11
    Join Date
    Oct 2014
    Posts
    32
    Thanks
    62
    Thanked 6 Times in 4 Posts
    EP Points
    60

    Default

    I am having the same problem, but ONLY specifically with the very first Battle Arena Toshinden. I have checked and confirmed CPU Overclocking is set to 1x.

    ePSXe works fine for all other titles that I have tested.

Similar Threads

  1. ePSXe games running too fast, FPS limiter doesnt work
    By mentalpiggie in forum Sony systems
    Replies: 4
    Last Post: 28th-September-2017, 21:50
  2. Replies: 4
    Last Post: 19th-May-2012, 17:29
  3. My games run too fast
    By x-D-x in forum Everything Emulation
    Replies: 5
    Last Post: 21st-July-2005, 19:30
  4. Wetrix runs too fast on Project64! Any suggestions?
    By PJYelton in forum Everything Emulation
    Replies: 6
    Last Post: 27th-April-2004, 10:49
  5. using epsxe 1.52 and games run too fast
    By mj_1107 in forum Everything Emulation
    Replies: 2
    Last Post: 8th-August-2003, 09:24

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About Us

We are the oldest retro gaming forum on the internet. The goal of our community is the complete preservation of all retro video games. Started in 2001 as EmuParadise Forums, our community has grown over the past 18 years into one of the biggest gaming platforms on the internet.

Social