Results 1 to 3 of 3

Thread: ePSXe Controller mapping problem

  1. #1
    Join Date
    Aug 2018
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question ePSXe Controller mapping problem

    Hey, i've been searchiing for a fix for this everywhere, but no dice, if it is already answered somewhere, i'm sorry in advance.

    I've been playing ePSXe 1.9.0 with netplay plugins to play certain games with my brother, and everything was working perfectly fine up until a few days ago, but my controllers randomly stop working,

    I checked to see if anything unmapped itself, but everythings as I left it, and as a last ditch effort to fix it, I tried remapping everything again, and upon entering button commands, it seems like it's forcing certain mappings itself.

    Example, if I'm trying to map The X button to button 1, I have to hold it down, or else it gets overwritten by J1_BUP

    Same goes for every other input, J1_BUP

    Goes for dual analog types, regular types, dual shock, etc.

    on occassion i change controller types and it works for around 10 minutes, then it stops itself and gives me that J1_BUP bs. It gets irritating having 10 minutes of uninterrupted gameplay for my controls to stop halfway through a level or mission, and i'm unable to save.

    I'm using a ps3 controller, i've tried my ps4 controller, i've tried my usb controllers, and i've tried third party gamecube to usb drivers for wii u adapters. All with only 1 controller at a time plugged in. (In case i had i bum controller) but on all their respective consoles, they work perfectly fine. Just regardless of what I do, it seems to keep forcing the J1_BUP on all button bindings. (All controllers plugged in i've been able to get to work on PC on anything but ePSXe since this happened.)

    I'm at a loss, I wiped the registry for epsx and reconfigured everything. I don't know what the next step would be.

    Any ideas guys? Thanks
    Last edited by glathal; 2nd-August-2018 at 23:53.

  2. #2
    Join Date
    Aug 2007
    Location
    a place I may die
    Posts
    1,439
    Thanks
    37
    Thanked 76 Times in 68 Posts
    Blog Entries
    1
    EP Points
    255

    Default

    If it was only happening with one controller, it sounds like an analog stick is slightly screwed up. If you managed to Cancel when your buttons changed to J1_BUP, you can press F5 to switch to Digital controller mode which disables the analog sticks. It's just like pressing the Analog button on a PS1 Dual Shock controller.


    Be afraid. Be very afraid.

  3. #3
    Join Date
    Aug 2018
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by skullpoker View Post
    If it was only happening with one controller, it sounds like an analog stick is slightly screwed up. If you managed to Cancel when your buttons changed to J1_BUP, you can press F5 to switch to Digital controller mode which disables the analog sticks. It's just like pressing the Analog button on a PS1 Dual Shock controller.
    I thought of that too, but i've tried other emulators, and games that support my controllers, even like smash brothers melee for example, where even the tiniest up input on a controller would result in some kind of action. I've troubleshoot multiple emulators with all of my controllers (Around 4 or 5) I've only had this trouble with ePSXe, All my controllers seem to work flawlessly with everything but ePSXe as of a few nights ago. which leads me to believe it's a software problem?

    Also, it even did the inputs when my controllers were unplugged, I've tried as much as to play with the keyboard alone with nothing else plugged up. same deal.
    Last edited by glathal; 3rd-August-2018 at 06:28.

Similar Threads

  1. Replies: 4
    Last Post: 2nd-June-2017, 02:50
  2. epsxe data transfer problem
    By ranma2222000 in forum Everything Emulation
    Replies: 1
    Last Post: 23rd-September-2005, 20:02
  3. epsxe frame rate problem
    By durstman2050 in forum Everything Emulation
    Replies: 2
    Last Post: 20th-August-2002, 07:45
  4. EpsxE ..And.....Xenogears Problem..
    By dumpsterdamon in forum Everything Emulation
    Replies: 2
    Last Post: 28th-June-2002, 14:41
  5. epsxe virtual cd problem
    By Khmerbreakerz in forum Everything Emulation
    Replies: 3
    Last Post: 8th-January-2002, 20:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About Us

We are the oldest retro gaming forum on the internet. The goal of our community is the complete preservation of all retro video games. Started in 2001 as EmuParadise Forums, our community has grown over the past 18 years into one of the biggest gaming platforms on the internet.

Social