Results 1 to 5 of 5

Thread: ePSXe games running too fast, FPS limiter doesnt work

  1. #1
    Join Date
    Sep 2017
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default ePSXe games running too fast, FPS limiter doesnt work

    Hardware;

    Processor:
    Intel i5-7500 running at 3.40GHz 4 cores.

    GPU:
    Nvidia GeForce GTX960

    ram:
    16GB DDR4 2133

    Operating system:
    Windows 10 x64.

    These are my current video settings, i've also tried turning autodetect on.
    Spoiler warning:
    Name:  94dabf5b571d681947ae55f5c1d0f6cd.png
Views: 2636
Size:  31.4 KB


    Plugins:
    standard ones, and Pete's OpenGL2 Driver 2.9 . If i put the limiter on 60fps, it fixes the cutscenes but game is waaay too fast to even play.

    Games im playing are Harry potter and the sorcerers stone and harry potter and the chamber of secrets, both have the same issues.



    if you need any more info i will try to supply it.
    Last edited by mentalpiggie; 27th-September-2017 at 21:47.

  2. #2
    Zorlon's Avatar
    Zorlon is offline Older than you think
    Still loves Retro gaming
    Still loves new consoles
    Part time games modder
    Just here to help out when I can
    Join Date
    Jun 2002
    Location
    UK Newcastle
    Posts
    22,210
    Thanks
    177
    Thanked 2,087 Times in 1,315 Posts
    Blog Entries
    5
    EP Points
    11655

    Default

    What special game fixes are enabled?? that may be the cause of the issue

    P.S. FPS should 63 for NTSC games (ePSXe timing is a little off)

    You could also take the jump and just switch to Retroarch instead of ePSXe

    Mod projects - XBOX
    Phantasy Star Online Episodes 1 & 2 - online quests in offline mode packs [COMPLETE]
    [Quest Packs Collection]
    GTA San Andreas - Hot Coffee [COMPLETE]
    [Mod ready] & [Full ISO ready]
    GTA San Andreas - Real Car Names extra content mod [WIP] [Back burner, just won't have the time ]
    Please can all ESR users post your results here to help with the project and others wanting to use ESR

  3. #3
    Join Date
    Sep 2017
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by Zorlon View Post
    What special game fixes are enabled?? that may be the cause of the issue

    P.S. FPS should 63 for NTSC games (ePSXe timing is a little off)

    You could also take the jump and just switch to Retroarch instead of ePSXe
    none, i tried some things but none of them worked so i turned all of them off, basically its just the checkbox might as well be turned off.

    Retroarch is working, thanks for the suggestion
    Last edited by Zorlon; 28th-September-2017 at 19:07.

  4. #4
    Zorlon's Avatar
    Zorlon is offline Older than you think
    Still loves Retro gaming
    Still loves new consoles
    Part time games modder
    Just here to help out when I can
    Join Date
    Jun 2002
    Location
    UK Newcastle
    Posts
    22,210
    Thanks
    177
    Thanked 2,087 Times in 1,315 Posts
    Blog Entries
    5
    EP Points
    11655

    Default

    Just happy you got your game working

    Mod projects - XBOX
    Phantasy Star Online Episodes 1 & 2 - online quests in offline mode packs [COMPLETE]
    [Quest Packs Collection]
    GTA San Andreas - Hot Coffee [COMPLETE]
    [Mod ready] & [Full ISO ready]
    GTA San Andreas - Real Car Names extra content mod [WIP] [Back burner, just won't have the time ]
    Please can all ESR users post your results here to help with the project and others wanting to use ESR

  5. #5
    Join Date
    Sep 2017
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by Zorlon View Post
    Just happy you got your game working
    me too! thanks again!

Similar Threads

  1. Replies: 4
    Last Post: 19th-May-2012, 17:29
  2. My games run too fast
    By x-D-x in forum Everything Emulation
    Replies: 5
    Last Post: 21st-July-2005, 19:30
  3. Running too fast
    By goodpepsi in forum Everything Emulation
    Replies: 8
    Last Post: 13th-August-2004, 19:01
  4. Wetrix runs too fast on Project64! Any suggestions?
    By PJYelton in forum Everything Emulation
    Replies: 6
    Last Post: 27th-April-2004, 10:49
  5. using epsxe 1.52 and games run too fast
    By mj_1107 in forum Everything Emulation
    Replies: 2
    Last Post: 8th-August-2003, 09:24

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About Us

We are the oldest retro gaming forum on the internet. The goal of our community is the complete preservation of all retro video games. Started in 2001 as EmuParadise Forums, our community has grown over the past 18 years into one of the biggest gaming platforms on the internet.

Social